--------------------- PatchSet 6495 Date: 2008/01/11 04:53:31 Author: amosjeffries Branch: ayjwork Tag: (none) Log: Define names for some debug levels. This allows the use of DBG_CRITICAL and DBG_IMPORTANT instead of magic numbers in the debugs() calls. Making code a little more readable and easier of use. TODO: the other levels (2-8) still need deciding. No consensus was reached amongst the developers for those when discussed. Members: src/Debug.h:1.8.8.3->1.8.8.4 Index: squid3/src/Debug.h =================================================================== RCS file: /cvsroot/squid-sf//squid3/src/Debug.h,v retrieving revision 1.8.8.3 retrieving revision 1.8.8.4 diff -u -r1.8.8.3 -r1.8.8.4 --- squid3/src/Debug.h 18 Dec 2007 13:07:24 -0000 1.8.8.3 +++ squid3/src/Debug.h 11 Jan 2008 04:53:31 -0000 1.8.8.4 @@ -1,5 +1,5 @@ /* - * $Id: Debug.h,v 1.8.8.3 2007/12/18 13:07:24 amosjeffries Exp $ + * $Id: Debug.h,v 1.8.8.4 2008/01/11 04:53:31 amosjeffries Exp $ * * DEBUG: section 0 Debug Routines * AUTHOR: Harvest Derived @@ -52,6 +52,12 @@ #define assert(EX) ((EX)?((void)0):xassert("EX", __FILE__, __LINE__)) #endif +/* defined names for Debug Levels */ +#define DBG_CRITICAL 0 /**< critical messages always shown when they occur */ +#define DBG_IMPORTANT 1 /**< important messages always shown when their section is being checked */ +/* levels 2-8 are still being discussed amongst the developers */ +#define DBG_DATA 9 /**< output is a large data dump only necessary for advanced debugging */ + class Debug {